Cisco 877 bridge with ASA5505
I have recently had a need to bridge a Cisco 877 and Cisco ASA5505 as I only had one IP Address available to me via a BE ADSL service.
Cisco 877 bridge configuration:
Building configuration…
Current configuration : 1103 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 877BridgedASA
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
dot11 syslog
ip cef
!
username dMb privilege 15 secret 0 password
!
archive
log config
hidekeys
!
bridge irb
!
interface ATM0
no ip address
no ip route-cache cef
no ip route-cache
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
no ip route-cache
atm route-bridged ip
pvc 0/101
encapsulation aal5snap
!
bridge-group 1
!
interface FastEthernet0
switchport access vlan 2
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface Vlan1
no ip address
no ip route-cache cef
no ip route-cache
!
interface Vlan2
no ip address
bridge-group 1
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane
!
bridge 1 protocol ieee
!
line con 0
no modem enable
line aux 0
line vty 0 4
login local
!
scheduler max-task-time 5000
end
Cisco ASA5505 configuration
ASA Version 8.4(3)
!
hostname ciscoasa
enable password passwordhere encrypted
passwd passwordhere encrypted
names
!
interface Ethernet0/0
description Link To Cisco 877 Router
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.229.254 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address 78.xxx.xxx.193 255.255.248.0
!
ftp mode passive
object network obj_any
subnet 0.0.0.0 0.0.0.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
!
object network obj_any
nat (inside,outside) dynamic interface
!
nat (inside,outside) after-auto source dynamic any interface
route outside 0.0.0.0 0.0.0.0 78.xxx.xxx.1 1
timeout xlate 3:00:00
timeout pat-xlate 0:00:30
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
user-identity default-domain LOCAL
http server enable
http 0.0.0.0 0.0.0.0 inside
http 0.0.0.0 0.0.0.0 outside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
crypto ca trustpoint _SmartCallHome_ServerCA
crl configure
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
prompt hostname context
call-home reporting anonymous
Cryptochecksum:6570e0d68627aa70f6d9540ccb909aa1
: end